去除WP 2.8新版本升级提醒

  Wordpress在向官网查询版本时丢掉了一个参数local_package,于是不停的报告有新版本。在Wordpress中文版中,有一个变量定义语句关于local_package的,wp2.7.1就有,而wp2.8丢掉了这一个变量定义。而且wp-includes/version.php文件根本就没有写完整,最后还丢掉一个“?>”这一个php的代码结束标志符。

昨天将Wordpress 2.71升级到了2.8_CN,插件兼容性方面一切正常,但是在升级后还会一直提醒有新版本可供升级,有些纳闷,没有深究,看着碍眼就把该提醒隐藏了。后来在论坛上版主发了个帖子解决了该问题,相信还有很多已经升级的和准备升级的朋友会遇到此问题,转来和大家分享下:

  原因:

  Wordpress在向官网查询版本时丢掉了一个参数local_package,于是不停的报告有新版本。在Wordpress中文版中,有一个变量定义语句关于local_package的,wp2.7.1就有,而wp2.8丢掉了这一个变量定义。而且wp-includes/version.php文件根本就没有写完整,最后还丢掉一个“?>”这一个php的代码结束标志符。

  解决方法:

  找到wp-includes/version.php文件,在文件最后加入以下代码:

  再把WP官方漏掉的“?>”补写完整就OK了。重新登陆,依次点击“控制台-工具-升级”刷新完缓存,就不会再有新版本提示了。

  此问题已经反映给Wordpress CN 负责人Paveo Chen了,并回复说会尽快解决。他给出的回答的解决方法也是这样的,所以这个就是标准的解决方法了。

Wopus评论:

这个问题的出现大概是从WordPress推出官方中文版开始的,从那个版本开始一直持续有这个问题,而且也有不少朋友询问是什么原因,上面说明了解决办法,大家可以先尝试解决,也希望官方能尽快解决这个问题。

其实Wopus一直都认为,WordPress此举是在强行推广官方中文版,因为使用官方英文版一直都没这个问题,只有中文版是这样,但看了这篇文章,这种说法基本上就不成立了,其实多重版本并行发展,由用户自己来选择使用,才是最好的选择,当然,既然是官方,自然会得到大家的亲睐,不管如何,大家都是为了推广WordPress,所以其他事情不必计较。


官方运营-Sean丶♥

692 SEO文章 文章

评论